Einrichtung Mikrotik

Mit folgendem Skript können Sie Ihren DDNS-Hostnamen mit einem Mikrotik Router aktualisieren:

 

:local FIPHostId "host-id"
:local FIPPASS "Passwort"
:local FIPDomain "subdomain.feste-ip.net"
:local WANInter "WAN"
:local IpCurrent [/ip address get [find interface=$WANInter] address];
:for i from=( [:len $IpCurrent] - 1) to=0 do={
  :if ( [:pick $IpCurrent $i] = "/") do={
    :local NewIP [:pick $IpCurrent 0 $i];
    :if ([:resolve $FIPDomain] != $NewIP) do={
     /tool fetch mode=http user=$FIPHostId password=$FIPPASS url="http://members.feste-ip.net/nic/update\3Fhostname=$FIPDomain&myip=$NewIP" keep-result=no
      :log info "FIP Update: $FIPDomain - $NewIP"
     }
   }
}